Exact Online - Not subscribed for PEPPOL while verification completed (BE)

Incident Report for Exact System

Identified

The issue has been identified and we are currently working on a fix.
Posted Apr 28, 2025 - 09:36 CEST

Investigating

You may experience that you are not subscribed for PEPPOL while your company and bank account are verified completely. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Apr 28, 2025 - 09:36 CEST
This incident affects: Exact Online.