Exact Online - Statements Knab (non PSD2) not delivered yet (NL)
Incident Report for Exact System
Resolved
The Knab bank statements (non PSD2) are now delivered and you can find them in your company. Our apologies for the inconvenience.
Posted Jun 05, 2024 - 12:37 CEST
Investigating
The Knab bank statements (non PSD2) are not delivered yet. An update will be shared as soon as more information is available. Our apologies for the inconvenience.
Posted Jun 04, 2024 - 08:54 CEST
This incident affected: Exact Online.