The company transfer wizard is available again. Our apologies for the inconvenience.
Posted Nov 18, 2024 - 09:05 CET
Investigating
It is currently not possible to start or accept company transfers. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Nov 15, 2024 - 17:41 CET
This incident affected: Exact Online and Exact Online Premium.