This incident has been resolved! The website is responsive and previewing annual reports is possible again without getting a time-out message.
Posted Mar 20, 2025 - 13:04 CET
Investigating
We are currently experiencing significant delays in our website response time on https://app.fiscaalgemak.nl/. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Mar 20, 2025 - 11:48 CET
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.