Possible performance issues.
Incident Report for Exact System
Resolved
It is possible to experience some slowness. We investigated the issue, it seems to be caused by poor internet connection caused by issues at Telenet. We apologize for the inconvenience.
Posted Sep 20, 2021 - 11:30 CEST
Investigating
Some customers can experience slowness, we are investigating.
Posted Sep 20, 2021 - 11:08 CEST
This incident affected: Belgium (Accountancy, Boekhouden, Digitale Brievenbus, Handel, Mijn [Kantoor], Productie, Project Management, Scan & Herken, Support department, Uren & Facturen).