Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 16, 2025 - 20:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 15, 2025 - 15:24 CET
Scheduled
Due to scheduled maintenance it will not be possible to send and receive invoices using or register to the PEPPOL network on Thursday January 16th between 20:00 CET and 21:00 CET. Sending invoices via PEPPOL may result in an error message. Please refrain from registering to the PEPPOL network during this maintenance, as registrations may not be verified automatically and therefore cause a delay.