This issue has been resolved, and all previously sent documents are processed successfully. There is no need to resend the documents to the digital postbox again. Our apologies for the inconvenience.
Posted Aug 18, 2025 - 14:38 CEST
Investigating
You may notice that documents sent to your digital postbox are not being received. We are currently investigating this issue. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Aug 18, 2025 - 11:29 CEST
This incident affected: Exact Online and Exact Online Premium.