Exact Online - 'Payment failed' error after paying Sales invoice using Mollie payment link (NL/BE)

Incident Report for Exact System

Identified

The issue has been identified and we are working on a solution.
Posted Jun 26, 2025 - 14:09 CEST

Update

After investigation only payments with the Mollie payment link are affected. The Exact payment link is working as intended.
We are investigating the issue regarding the Mollie payment link. Our apologies for the inconvenience.
Posted Jun 26, 2025 - 11:25 CEST

Investigating

It's possible that you do not get a payment confirmation after using either the Exact or Mollie payment link. It's also possible that you get the error: 'Payment failed - An error occurred during payment of the sales invoice'. Please verify on your bank account whether the payment was successful to prevent double payment. We are investigating the issue. Our apologies for the inconvenience.
Posted Jun 25, 2025 - 15:56 CEST
This incident affects: Exact Online and Exact Online Premium.