A fix has been implemented, and we are monitoring the results.
Posted Jan 15, 2026 - 11:50 CET
Investigating
When doing a software update, or when starting the software, the warning "This certificate is expired or not valid" can appear. We are investigating the issue. Once more information is available, we will update this page. Our apologies for the inconvenience.
Posted Jan 15, 2026 - 08:54 CET
This incident affected: Exact Globe+, Exact Globe Next, and Exact Synergy.