Exact Online - Unable to log in (Global)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Apr 09, 2025 - 15:25 CEST

Monitoring

A fix has been implemented and logging in is possible again. We are monitoring the results of the fix.
Posted Apr 09, 2025 - 13:00 CEST

Investigating

We are currently experiencing issues on our log in page. When you try to log in you receive an error 'Something went wrong. Please try again later'. We are investigating this issue. Our apologies for the inconvenience.
Posted Apr 09, 2025 - 11:57 CEST
This incident affected: Exact Online and Exact Online Premium.