Exact Status Page

Exact Online Premium - Performance issues in Exact Online Premium (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. When still experiencing performance issues you can delete the cookies and cache in your browser. Our apologies for the inconvenience.
Posted Jul 21, 2026 - 16:23 CEST

Monitoring

You may still be experiencing performance issues due to yesterday's issue. You can resolve the performance issues by deleting the cookies and cache in your browser. Our apologies for the inconvenience.
Posted Jul 21, 2026 - 09:32 CEST
This incident affected: Exact Online Premium.