Exact Status Page

Exact Cloud Services - Unable to log in to password portals (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Mar 31, 2026 - 15:15 CEST

Investigating

You may currently experience an issue where the registered key users cannot be used to log in to the password portals. We are investigating the issue. In case of urgency our support team can assist in a password reset. Our apologies for the inconvenience.
Posted Mar 31, 2026 - 09:53 CEST
This incident affected: Exact Cloud Services.