This issue has been resolved. You won't experience degraded performance anymore. Our apologies for the inconvenience.
Posted Dec 05, 2024 - 10:48 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2024 - 10:08 CET
Investigating
You may experience performance issues in Exact Premium through various menu paths. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.