Exact Boekhoud Gemak – Login page does not load (NL)
Incident Report for Exact System
Resolved
This incident has been resolved. Our apologies for the inconvenience.
Posted Jan 06, 2025 - 15:01 CET
Investigating
You may experience issues with Exact Boekhoud Gemak where the login page either does not load or you receive a blank screen when the page has finished loading. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Jan 06, 2025 - 14:17 CET
This incident affected: Exact Boekhoud Gemak.