Exact Online - Degraded performance via different menu paths (BE)

Incident Report for Exact System

Resolved

This issue has been resolved. You won't experience degraded performance via different menu paths anymore. Our apologies for the inconvenience.
Posted Mar 15, 2025 - 10:15 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2025 - 10:00 CET

Investigating

You may experience degraded performance via different menu paths. We are investigating this issue. As soon as an update is available we will update this page. Our apologies for the inconvenience.
Posted Mar 15, 2025 - 09:23 CET
This incident affected: Exact Online.