Exact Online Fiscaal & Jaarrekening- Performance issues in the app environment (NL)

Incident Report for Exact System

Resolved

This issue has been resolved and the performance of the app environment is back to normal again. Our apologies for the inconvenience.
Posted Sep 24, 2025 - 20:06 CEST

Investigating

There are performance issues in our app environment. You may experience errors or long waiting times. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Sep 24, 2025 - 16:25 CEST
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.