Exact Status Page

Exact Gripp - Contract portal unavailable (NL)

Incident Report for Exact System

Resolved

This issue has been resolved and access to the contract portal has been restored. Our apologies for the inconvenience.
Posted Jun 01, 2026 - 15:24 CEST

Monitoring

We have implemented a fix and are monitoring the results.
Posted Jun 01, 2026 - 11:34 CEST

Investigating

Currently it is not possible to access the contract portal and make changes to your subscription. We are investigation the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 01, 2026 - 10:30 CEST
This incident affected: Exact Gripp.