Messages sent to the digital postbox are not processed
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 16:51 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 26, 2021 - 08:15 CEST
Update
You may experience a short interruption to our services today due to maintenance. Our apologies for the inconvenience.
Posted Apr 24, 2021 - 10:22 CEST
Monitoring
The messages are being processed again. Because of the backlog it could take a while before you see your message in the digital postbox.
Posted Apr 23, 2021 - 18:37 CEST
This incident affected: Netherlands (Boekhouden, Scan & Herken) and Belgium (Boekhouden, Scan & Herken).