Exact Online Premium - Performance issues in Exact Online Premium (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted May 08, 2025 - 08:28 CEST

Update

We are continuing to monitor for any further issues.
Posted May 07, 2025 - 07:04 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2025 - 07:04 CEST

Investigating

You may experience performance issues via different menupaths in Exact Online Premium. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted May 06, 2025 - 11:58 CEST
This incident affected: Exact Online Premium.