ECS; Citrix cloud login issue

Incident Report for Exact System

Postmortem

The EU region for Citrix Cloud environments reported a fault. This impacted a limited number of people trying to login for a Citrix connection during the fault.

Posted Nov 17, 2023 - 10:05 CET

Resolved

The incident is resolved. An incident occurred in the EU region for Citrix.
Posted Nov 17, 2023 - 09:07 CET

Investigating

Customers using the Citrix cloud environment may experience login errors or delayed login
Posted Nov 17, 2023 - 08:53 CET
This incident affected: Exact Cloud Services.