Exact Online Premium - Bank statements have not been imported since the 25th of April (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Apr 28, 2025 - 16:36 CEST

Investigating

You may experience that no bank statements have been imported since the 25th of April. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Apr 28, 2025 - 10:32 CEST
This incident affected: Exact Online Premium.