Exact Multivers - Logging in to Exact Multivers not possible (NL)

Incident Report for Exact System

Resolved

The issues have been solved. Logging into Multivers Online should be possible again. If problems still occur, please contact Support. Our apologies for the inconvenience.
Posted Nov 24, 2025 - 11:59 CET

Investigating

You may experience issues logging in to Multivers Online. You will get an error with "This computer can't connect to the remote computer." We are investigating this issue. We will update this page as soon as more information is available. Our apologies for the inconvenience.
Posted Nov 24, 2025 - 09:09 CET
This incident affected: Exact Multivers.