Exact Status Page

Exact Online - Performance issues in Exact Online (NL/BE)

Incident Report for Exact System

Resolved

Exact Online has been working as expected again since 13.25. Our apologies for the inconvenience.
Posted Jul 16, 2026 - 15:01 CEST

Monitoring

A fix has been implemented and performance is back to usual. We are monitoring the results.
Posted Jul 16, 2026 - 13:25 CEST

Investigating

You may experience degraded performance in Exact Online. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jul 16, 2026 - 12:50 CEST
This incident affected: Exact Online.