Exact Online Samenwerken - The website is currently unavailable (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted Apr 25, 2025 - 11:26 CEST

Investigating

You may experience error messages or you are not able to reach the website of Exact Online Collaboration. You may also experience that emails are not delivered. We are investigating these issues and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Apr 25, 2025 - 09:43 CEST
This incident affected: Exact Online Collaboration.