Exact Status Page

Exact Online Premium - Login not possible in Exact Online Premium (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. Exact Online Premium is available again. Our apologies for the inconvenience.
Posted Apr 09, 2026 - 10:22 CEST

Monitoring

We have implemented a fix and we are monitoring the results.
Posted Apr 09, 2026 - 10:07 CEST

Investigating

You may experience that it is not possible to access Exact Online Premium. We are investigating the issue. Our apologies for the inconvenience.
Posted Apr 09, 2026 - 10:01 CEST
This incident affected: Exact Online Premium.