The issue has been identified and we are working on a fix.
Posted Oct 13, 2025 - 14:37 CEST
Investigating
You may experience that the entry number is not fully visible in the bank entry screen because the field is too narrow. We are investigating the issue. We will update this page once more information is available. Our apologies for the inconvenience.
Posted Oct 10, 2025 - 19:58 CEST
This incident affects: Exact Online and Exact Online Premium.