This issue has been resolved. All sent emails are now visible in Exact Online
Posted Jun 25, 2025 - 15:33 CEST
Monitoring
Sent mails to the digital postbox are now being processed and should soon be visible in Exact Online. It's not necessary to resend the mails to the digital postbox as they are now being processed. Our apologies for the inconvenience.
Posted Jun 25, 2025 - 12:57 CEST
Investigating
It's possible that mails sent to the digital postbox are not received in Exact Online. We are investigating the issue. Our apologies for the inconvenience.