Exact Status Page

Exact Online - Delivery address not visible on purchase orders and delivery notes for dropshipment orders (Global)

Incident Report for Exact System

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2026 - 14:35 CEST

Investigating

You may experience that the delivery address is not visible on the purchase order or delivery note for dropshipment orders. We are investigating this issue, and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Apr 01, 2026 - 10:44 CEST
This incident affects: Exact Online and Exact Online Premium.