The issue has now been resolved for Rabobank customers. For other banks we are still working on a solution. For newly created payment files that need to be approved via an Exact PSD2 connection for Rabobank, the issue has been resolved and the status column is updated.
Posted Jul 31, 2026 - 15:22 CEST
Update
We are continuing to work on a fix.
Posted Jul 10, 2026 - 13:48 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 01, 2026 - 08:08 CEST
Investigating
You may experience that the Status column in the Bank files overview is not updated after you have authorized a payment file via a PSD2 bank link. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.