The issue has now been resolved. All ABN AMRO statements have been imported successfully. Our apologies for the inconvenience.
Posted Nov 23, 2023 - 17:11 CET
Identified
All ABN AMRO statements with entry date November 21st have been imported successfully. The import of the statements with entry date November 22nd will start soon. This page will be updated as soon as all ABN AMRO statements have been imported.
Posted Nov 23, 2023 - 13:42 CET
Update
The statements with entry date November 22nd have not yet been imported. As soon as all ABN AMRO statements with entry date November 21st have been received successfully, we will start today's import so that all ABN AMRO statements will be imported in chronological order. Please refrain from importing statements manually since this may cause duplicate statements. Our apologies for the delay.
Posted Nov 23, 2023 - 08:33 CET
Investigating
The bank statements of ABN AMRO (1.0 bank link) are not all delivered yet. The bank is working hard to solve this issue. Our apologies for the inconvenience caused.