Exact Status Page

Exact Online - Unable to select option Receive in e-invoice subscription (FR)

Incident Report for Exact System

Identified

The issue has been identiefied. We are working on a solution.
Posted Aug 20, 2026 - 12:03 CEST

Investigating

When subscribing for e-invoicing you will receive the error message "Due to a technical error, we couldn't verify if your company is already registered on the Peppol network. The option to receive invoices is therefore disabled. Please try again later." preventing you from selecting the option to receive e-invoices. We are investigating the issue and will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Aug 20, 2026 - 10:21 CEST
This incident affects: Exact Online.