Exact Status Page

Exact Multivers - Not possible to send VAT and ICP returns digitally (NL)

Incident Report for Exact System

Resolved

The issue has been resolved and you are able to send VAT and ICP returns again via Exact Multivers. You might need to reopen the returns in order to send the returns again. Our apologies for the inconvenience.
Posted Jul 29, 2026 - 11:43 CEST

Investigating

You may face an error message stating that the digital sending has failed when sending a VAT of ICP return via Exact Multivers. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jul 29, 2026 - 10:28 CEST
This incident affected: Exact Multivers.