Exact Online - Not able to setup a bank link (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. It is possible to setup a bank link in your company again. Our apologies for the inconvenience.
Posted Mar 26, 2025 - 14:26 CET

Investigating

You may experience issues when setting up a bank link in your company. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Mar 26, 2025 - 14:02 CET
This incident affected: Exact Online.