Exact Online - Backup functionality unavailable (US)

Incident Report for Exact System

Resolved

The backup functionality is available in the US legislation of Exact Online again. Our apologies for the inconvenience.
Posted Oct 01, 2025 - 15:01 CEST

Identified

It is currently not possible to create backups in the US legislation of Exact Online. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Sep 30, 2025 - 13:22 CEST
This incident affected: Exact Online.