A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2024 - 16:33 CET
Identified
This issue has been identified and currently we are working on a fix.
Posted Nov 21, 2024 - 10:49 CET
Investigating
You may experience that your search in the item overview gives no results. We are investigating this issue. Please be advised that the blue search bar in the top right of your screen can be used as an alternative in the meantime. This page will be updated as soon as more information is available. Our apologies for the inconvenience.