Exact Winbooks/Exact Venice - Oops error when registering for or maintaining Peppol (BE)

Incident Report for Exact System

Update

This issue affects both Exact Winbooks and Exact Venice. We are investigating the issue and will update this page as soon as more information becomes available.
Posted Jan 12, 2026 - 21:29 CET

Investigating

You may experience an oops error when registering for and maintaining existing Peppol registrations. We are investigating the issue and will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jan 12, 2026 - 17:42 CET
This incident affects: Exact Winbooks and Exact Venice.