This issue has been resolved. Our apologies for the inconvenience.
Posted Apr 01, 2026 - 11:25 CEST
Update
This issue has been resolved. Our apologies for the inconvenience.
Posted Apr 01, 2026 - 11:25 CEST
Investigating
You may experience performance issues via different menupaths. We are currently investigating this issue. You can expect status updates as soon as new information is available. Our apologies for the inconvenience.
Posted Apr 01, 2026 - 09:48 CEST
This incident affected: Exact Online Payroll & HR and Exact Officient.