A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2025 - 07:13 CET
Identified
The issue has been identified and we are working on a fix.
Posted Mar 06, 2025 - 13:32 CET
Investigating
Currently bank accounts are shown next to each other instead of on top of each other in the financial dashboard. The issue only occurs when automatic bank links are enabled. We are investigating the issue. Our apologies for the inconvenience.
Posted Mar 05, 2025 - 09:30 CET
This incident affected: Exact Online and Exact Online Premium.