Exact Online Premium - Performance issues Exact Online Premium (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Apr 28, 2025 - 15:29 CEST

Investigating

You may experience performance issues via different menupaths in Exact Online Premium. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Apr 28, 2025 - 14:53 CEST
This incident affected: Exact Online Premium.