Exact Status Page

Exact Online (BE) Not possible to download documents from search transactions screen.

Incident Report for Exact System

Resolved

This issue has been resolved. You will be able to download your documents again via the search transactions page. Our apologies for the inconvenience.
Posted Jun 11, 2026 - 14:48 CEST

Investigating

You may receive an error message stating 'A problem has occurred For more information please contact Customer Support' when trying to download documents via the search transaction screen. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 11, 2026 - 11:15 CEST
This incident affected: Exact Online.