This issue has now been resolved and all statements have been imported. Our apologies for the inconvenience.
Posted Dec 10, 2025 - 08:45 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 13:03 CET
Investigating
You may experience that the statements of your Exact PSD2-bank links in Exact Online Premium have not been imported yet. We are currently investigating this issue. When an update is available, we will inform you. Our apologies for the inconvenience.
Posted Dec 09, 2025 - 11:56 CET
This incident affected: Exact Online Premium and Bank links / PSD2.