Exact Status Page

Exact Reeleezee - Bank statements not imported via ING and Knab bank connections (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. All ING and Knab bank statements have been delivered. Our apologies for the inconvenience.
Posted Mar 16, 2026 - 16:02 CET

Investigating

Since Friday, March 13th, our connections with ING and KNAB Bank have been experiencing issues. This affects transaction syncing and the sending of payment/collection orders. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Mar 16, 2026 - 11:13 CET
This incident affected: Exact Reeleezee.