This issue has been resolved, and performance has returned to normal. Apologies for the inconvenience.
Posted Nov 25, 2024 - 22:05 CET
Update
We are continuing to investigate this issue.
Posted Nov 25, 2024 - 16:33 CET
Investigating
You may experience performance issues in Exact Premium through various menu paths. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.