Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2024 - 08:00 CET
Scheduled
Due to maintenance, Exact Online Premium will be unavailable on Saturday 7 December between 08:00 CEST and 09:00 CEST. Creating an accountant link with an Exact Online Premium customer is also unavailable. Our apologies for the inconvenience.
Posted Dec 02, 2024 - 14:38 CET
This scheduled maintenance affected: Exact Online Premium.