Exact Online - Not able to start a support chat or create a supportcase (Global)

Incident Report for Exact System

Resolved

The issue has been resolved. It is possible to create a supportcase or start a support chat again. Our apologies for the inconvenience.
Posted Mar 27, 2025 - 11:13 CET

Investigating

Currently we are facing technical issues with the Exact Support page. As a result, you are not able to create a supportcase or start a support chat at this moment. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Mar 27, 2025 - 09:28 CET
This incident affected: Customer Support Department.