This issue has been resolved. All uploaded scans are processed. Our apologies for the inconvenience.
Posted Nov 19, 2024 - 12:19 CET
Identified
The issue has been identified and the uploaded scans are being processed.
Posted Nov 18, 2024 - 10:58 CET
Investigating
You may experience that your uploaded scans remain longer 'in progress' than expected. As soon as more information becomes available, we will update this page. Our apologies for the inconvenience.