The issue has been resolved. It is possible again to register for Peppol without facing unexpected errors. Our apologies for the inconvenience.
Posted Jan 16, 2026 - 13:22 CET
Identified
The issue has been identified and a fix is being implemented. This issue only occurs when you try to register for Peppol with the same user you have used to register Peppol in Exact Online. Therefore, please refrain from onboarding your company in Bouw with the same user you used to onboard your company in Exact Online.
Posted Dec 19, 2025 - 15:34 CET
Investigating
Currently you cannot complete your Peppol registration when the company you are trying to register is already subscribed to Peppol in Exact Online. During the onboarding process you receive a selection of multiple accounts, but selecting an account results in an 'access denied' error. We are investigating the issue. Our apologies for the inconvenience.