The implemented fix has solved the issue. Our apologies for the inconvenience.
Posted Jan 16, 2025 - 09:46 CET
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jan 16, 2025 - 09:25 CET
Investigating
You may experience an error saying “Failed to launch application" when trying to log in to Citrix. We are currently investigating this issue. We will post updates on this page as soon as more information becomes available. Our apologies for the inconvenience.