Exact Online Fiscaal en Jaarrekening - Delayed website response on https://app.fiscaalgemak.nl (NL)

Incident Report for Exact System

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 20:47 CEST

Investigating

We are currently experiencing significant delays in our website response time on https://app.fiscaalgemak.nl/. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Apr 10, 2025 - 17:06 CEST
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.