Exact Online - ING bank statements for non-PSD2 bank links not delivered yet (NL)

Incident Report for Exact System

Resolved

The ING bank statements (non PSD2) are delivered. Apologies for the inconvenience.
Posted Jun 27, 2024 - 13:32 CEST

Identified

The ING bank statements (non PSD2) are not delivered yet. An update will be shared as soon as more information is available. Our apologies for the inconvenience.
Posted Jun 27, 2024 - 09:02 CEST
This incident affected: Bank links / PSD2.